ResidualVM logo Forum Index - ResidualVM website - Contact us - Rules Login    Register     Search curved edge
It is currently Sat Jan 18, 2020 11:34 am

All times are UTC




Post new topic Reply to topic  [ 4 posts ] 
Author Message
PostPosted: Sun Sep 07, 2014 10:37 am 
Offline

Joined: Sun Sep 07, 2014 10:23 am
Posts: 2
Hello,

First of all - THANK YOU for the software. I'm now playing GF on my Win 8.1 laptop. :)

There's one issue - not a huge deal, but maybe someone could help. My laptop is an NVIDIA Optimus machine, which means I've got both an integrated Intel HD4600 and a separate GeForce GTX 765M. I can switch between them depending on which GPU I want for which application.

Obviously both GPUs can run GF silky smooth with no problems, but only the GTX allows me to force antialiasing, which helps a bit with the dated looks of GF. Problem is, the cutscenes are choppy - as if dropping frames. The 3D game itself runs flawlessly, it's just the cutscenes that act as if there's a performance bottleneck (obviously there isn't any). That's on the latest non-beta NVIDIA drivers.

On the other hand, the integrated HD4600 has no trouble with the cutscenes (they're perfectly smooth), but doesn't allow forced antialiasing - and since there's no in-game AA, well, jaggiefest it is.

Has anyone else encountered this issue and maybe knows a fix? Again, it's not a huge deal, but you know.


Top
 Profile  
 
PostPosted: Mon Sep 08, 2014 5:59 am 
Offline
ResidualVM Developer

Joined: Tue Mar 27, 2012 11:12 pm
Posts: 23
I have a laptop running Windows 7 with a Nvidia 310M and some Intel integrated card. I'm not seeing the problem you described here.

Are you using the nightly build, or the 0.1.1 release? Does it happen in both versions for you?

I don't really see how a different graphics card would really matter here as the cut scenes are decoded in software and then the screen size frames are rendered to screen. There doesn't seem to be a lot of room to be dropping frames...


Top
 Profile  
 
PostPosted: Mon Sep 08, 2014 7:37 pm 
Offline

Joined: Sun Sep 07, 2014 10:23 am
Posts: 2
I'm using 0.1.1. I've just tried the latest nightly build and there's no difference.

When I launch GF with the NVIDIA GPU, the LucasArts logo and the subsequent cigarette scene are smooth. The stuttering starts when that scene fades out into Mr Flores in Manny's office. All cutscenes from then on are affected. :/


Top
 Profile  
 
PostPosted: Tue Sep 09, 2014 10:44 am 
Offline
ResidualVM Developer

Joined: Thu Feb 28, 2013 5:48 pm
Posts: 207
Are you in a position to recompile ResidualVM from source? Otherwise i'd say give the shader-based renderer a try.

If not, can you run the game with some kind of performance tracing tool so we can see which functions take up time?
I've used gDEBugger in the past with good results.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Forum design by ScummVM team, icons by raina, adopted for ResidualVM
curved edge   curved edge