ResidualVM logo Forum Index - ResidualVM website - Contact us - Rules Login    Register     Search curved edge
It is currently Sun Apr 05, 2020 7:20 pm

All times are UTC




Post new topic Reply to topic  [ 10 posts ] 
Author Message
PostPosted: Sun Aug 24, 2014 7:42 am 
Offline

Joined: Sun Aug 24, 2014 6:41 am
Posts: 5
I would like to play Grim Fandango in true fullscreen. It's like letterbox, but vertical. Any help?


Top
 Profile  
 
PostPosted: Mon Aug 25, 2014 11:35 am 
Offline
ResidualVM Developer

Joined: Thu Feb 28, 2013 5:48 pm
Posts: 207
This is currently not possible with ResidualVM: fullscreen always takes the resolution demanded by the game.
We have discussed ways to fix it (https://github.com/residualvm/residualvm/issues/428, for example), but nobody has written the code yet.


Top
 Profile  
 
PostPosted: Mon Aug 25, 2014 11:52 am 
Offline

Joined: Sun Aug 24, 2014 6:41 am
Posts: 5
Botje wrote:
This is currently not possible with ResidualVM: fullscreen always takes the resolution demanded by the game.
We have discussed ways to fix it (https://github.com/residualvm/residualvm/issues/428, for example), but nobody has written the code yet.

I just want it stretched. I don't care about the quality. Before I formatted some days ago, the game would always stretch and I like it that way. So, there isn't a way, right?


Top
 Profile  
 
PostPosted: Mon Aug 25, 2014 11:56 am 
Offline
ResidualVM Developer

Joined: Thu Feb 28, 2013 5:48 pm
Posts: 207
ResidualVM just asks for 640x480 fullscreen.
What your OS/video card drivers/monitor decide to do is outside our control.

Since you stated that you reinstalled in the first post, maybe check the settings of your video card drivers and/or monitor settings?


Top
 Profile  
 
PostPosted: Mon Aug 25, 2014 11:59 am 
Offline

Joined: Sun Aug 24, 2014 6:41 am
Posts: 5
Botje wrote:
ResidualVM just asks for 640x480 fullscreen.
What your OS/video card drivers/monitor decide to do is outside our control.

Since you stated that you reinstalled in the first post, maybe check the settings of your video card drivers and/or monitor settings?

What I did was install a new AMD driver. Maybe that's the case. Bad thing is that AMD's Catalyst doesn't let you change the aspect ratio or something. Thank you for your help.


Top
 Profile  
 
PostPosted: Mon Aug 25, 2014 12:02 pm 
Offline
ResidualVM Developer

Joined: Thu Feb 28, 2013 5:48 pm
Posts: 207
This seems relevant, then:
http://support.amd.com/en-us/kb-article ... aling.aspx


Top
 Profile  
 
PostPosted: Mon Aug 25, 2014 12:15 pm 
Offline
User avatar

Joined: Tue Jul 19, 2011 2:51 am
Posts: 327
Location: aka ThunderPeel2001
GrimReminder wrote:
I would like to play Grim Fandango in true fullscreen. It's like letterbox, but vertical. Any help?


The game isn't supposed to be played widescreen. It was designed for 4:3 monitors. So having vertical black bars down the side is correct :-/


Top
 Profile  
 
PostPosted: Mon Aug 25, 2014 12:39 pm 
Offline

Joined: Sun Aug 24, 2014 6:41 am
Posts: 5
JohnnyWalker2001 wrote:
GrimReminder wrote:
I would like to play Grim Fandango in true fullscreen. It's like letterbox, but vertical. Any help?


The game isn't supposed to be played widescreen. It was designed for 4:3 monitors. So having vertical black bars down the side is correct :-/

I know... I just don't want them.


Top
 Profile  
 
PostPosted: Mon Aug 25, 2014 7:13 pm 
Offline

Joined: Sun Aug 24, 2014 6:41 am
Posts: 5
I solved it.


Top
 Profile  
 
PostPosted: Thu Aug 28, 2014 12:37 pm 
Offline
User avatar

Joined: Mon Sep 05, 2011 5:13 pm
Posts: 98
Go into your video card settings, find the options for resolution and set:
"keep aspect ratio - may cause black bars if resolutions have different aspect ratio"

That way the screen wont stretch when you change resolutions. Since GF works in 640x480 you should have black bars on the sides.

The video settings differ between GPU manufacturers and drivers, but the screen should look like this:

Image

Note: i found this pic on the net, the selected option in this pc is wrong for GF, it should be "Aspect Ratio"

Hope this helps

P.S. I just realized after posting it that this question has already been answered :D


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 

All times are UTC


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Forum design by ScummVM team, icons by raina, adopted for ResidualVM
curved edge   curved edge