ResidualVM Forum

ResidualVM :: Forum
It is currently Tue Sep 29, 2020 10:21 pm

All times are UTC




Post new topic  Reply to topic  [ 11 posts ] 
Author Message
 Post subject: Forklift troubles
PostPosted: Sat May 04, 2013 10:07 am 
Offline

Joined: Sat May 04, 2013 9:59 am
Posts: 6
I'm using ResidualVM 0.1.1 (Feb 10 2013 10:08:41) to play Grim Fandango.

There are many graphical glitches, but so far, the game remained playable. I have progressed to year 2 and now I'm trying to stop the lift. From back when I played the game 15 years ago, I remember that the lift somehow closed with a sort of grate. I cannot see such a thing now, though. So I'm sort of blindly driving the forklift in the direction where the door should be. About 50 attempts remained fruitless.

Is there a particular trick to this which I have forgotten or which I'm missing?


Top
   
 Post subject:
PostPosted: Mon May 06, 2013 9:16 am 
Offline
ResidualVM Developer
User avatar

Joined: Wed Nov 24, 2010 2:44 am
Posts: 325
There should be a gate, with to forklift-sized holes at the bottom. Could you post some screenshots of what exactly you DO see?


Top
   
 Post subject:
PostPosted: Mon May 06, 2013 1:37 pm 
Offline

Joined: Sat May 04, 2013 9:59 am
Posts: 6
Sure, here is a picture of the lift in motion:

Image


Top
   
 Post subject:
PostPosted: Mon May 06, 2013 1:48 pm 
Offline
ResidualVM Developer
User avatar

Joined: Wed Nov 24, 2010 2:44 am
Posts: 325
Which OS is it you run the game on? And are you using Software-rendering or 3D-Acceleration?


Top
   
 Post subject:
PostPosted: Mon May 06, 2013 1:51 pm 
Offline

Joined: Sat May 04, 2013 9:59 am
Posts: 6
This is on Debian Stable with OpenGL rendering (according to the options screen; I have not changed any settings there).


Top
   
 Post subject:
PostPosted: Mon May 06, 2013 1:52 pm 
Offline
ResidualVM Developer
User avatar

Joined: Wed Nov 24, 2010 2:44 am
Posts: 325
Ok, what graphics-card is this? And do you get the same issue if you change to software rendering (either via the in-game settings, or in the launcher).


Top
   
 Post subject:
PostPosted: Mon May 06, 2013 2:02 pm 
Offline

Joined: Sat May 04, 2013 9:59 am
Posts: 6
Ah! With software rendering, it all looks much clearer, thank you!

For the sake of completeness, lspci lists the graphics card as this:
Quote:
VGA compatible controller: ATI Technologies Inc RV620 LE [Radeon HD 3450]
The Xorg driver in use is "radeon".


Top
   
 Post subject:
PostPosted: Tue May 07, 2013 9:08 am 
Offline
ResidualVM Developer
User avatar

Joined: Wed Nov 24, 2010 2:44 am
Posts: 325
This does look like a bug though.


Top
   
 Post subject:
PostPosted: Tue May 07, 2013 1:27 pm 
Offline

Joined: Sat May 04, 2013 9:59 am
Posts: 6
Well, my personal problem has been solved. If I can help debugging some general issue by providing additional information or testing things, I will be glad to.


Top
   
 Post subject:
PostPosted: Tue May 07, 2013 5:47 pm 
Offline
ResidualVM Developer
User avatar

Joined: Wed Nov 24, 2010 2:44 am
Posts: 325
Which driver was this?


Top
   
 Post subject:
PostPosted: Tue May 07, 2013 8:02 pm 
Offline

Joined: Sat May 04, 2013 9:59 am
Posts: 6
The X driver, as per my post above. In-game, it was set to "OpenGL".


Top
   
Display posts from previous:  Sort by  
Post new topic  Reply to topic  [ 11 posts ] 

All times are UTC


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Limited