ResidualVM logo Forum Index - ResidualVM website - Contact us - Rules Login    Register     Search curved edge
It is currently Sat Aug 08, 2020 8:14 pm

All times are UTC




Post new topic Reply to topic  [ 212 posts ]  Go to page Previous  1 ... 4, 5, 6, 7, 8, 9, 10 ... 15  Next
Author Message
 Post subject:
PostPosted: Mon Sep 09, 2013 6:22 pm 
Offline
ResidualVM Developer

Joined: Thu Feb 28, 2013 5:48 pm
Posts: 207
There, I updated the APK with support for the menu key again. Turns out upping the SDK version makes it disappear.
The menu appears but is very hard to navigate..

Now, please, no more questions or requests about the controls.
Patches welcome, though.

The source is available at my GitHub fork of ResidualVM (https://github.com/Botje/residualvm).

APK: https://dl.dropboxusercontent.com/u/12346504/Android%20ResidualVM%20ES2%20Test.apk


Top
 Profile  
 
 Post subject:
PostPosted: Tue Sep 10, 2013 8:15 pm 
Offline

Joined: Wed Aug 28, 2013 8:47 am
Posts: 3
I CAN SAVE! :D Thank you very very much for this update!!
Navigation is ok. Game is now completely playable!


Top
 Profile  
 
 Post subject:
PostPosted: Tue Sep 10, 2013 10:53 pm 
Offline

Joined: Tue Sep 10, 2013 10:48 pm
Posts: 5
Location: United Kingdom
mitklaus wrote:
I CAN SAVE! :D Thank you very very much for this update!!
Navigation is ok. Game is now completely playable!


This is ace! Well done everyone involved in this great app.

Been testing with EMI. Only one problem for me - save works but load doesn't :-( . Just crashes the app. Have tried saving to different locations but still the same effect.

I'm using a Motorola Xoom tablet running ICS 4.0.4 and all default settings. I know this is experimental so don't expect everything to work but has anyone any pointers on this one?

Thanks.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Sep 11, 2013 10:00 am 
Offline

Joined: Wed Aug 28, 2013 8:47 am
Posts: 3
how did you try to load? Through the ResidualVM-Menue or during the game? Here both works perfect (Chuwi V88, RK3188).


Top
 Profile  
 
 Post subject:
PostPosted: Wed Sep 11, 2013 12:34 pm 
Offline

Joined: Tue Sep 10, 2013 10:48 pm
Posts: 5
Location: United Kingdom
mitklaus wrote:
how did you try to load? Through thfe ResidualVM-Menue or during the game? Here both works perfect (Chuwi V88, RK3188).


Both :-).

I'm using the latest apk that has the menu feature. Wasn't able to save at all before that neat addition.

Do you have any specific settings that may be making it work for you? My save location is on internal storage and I tried folders both inside and outside of the game directory.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Sep 11, 2013 12:38 pm 
Offline
ResidualVM Developer

Joined: Thu Feb 28, 2013 5:48 pm
Posts: 207
If it crashes the app, please provide a log of the crash so I can look into the error.
You can grab it with adb logcat, it should look something like http://pastebin.com/54d5EPSX (starting from line 252).


Top
 Profile  
 
 Post subject:
PostPosted: Wed Sep 11, 2013 10:06 pm 
Offline

Joined: Fri Aug 30, 2013 1:03 pm
Posts: 2
Thanks for the return of the MENU button! Works perfectly now and I can save too!


Top
 Profile  
 
 Post subject:
PostPosted: Thu Sep 12, 2013 10:28 pm 
Offline

Joined: Tue Sep 10, 2013 10:48 pm
Posts: 5
Location: United Kingdom
Botje wrote:
If it crashes the app, please provide a log of the crash so I can look into the error.
You can grab it with adb logcat, it should look something like http://pastebin.com/54d5EPSX (starting from line 252).


Great. Thanks Botje.

Logs available here:
https://docs.google.com/folder/d/0BylrL ... xrSUE/edit

Seems to be only an issue with EMI as I saved and loaded with Grim Fandango just fine. Also spotted one saved game that asked for CD2 when loading, but only saw that once so not sure if that's anything to worry about currently.


Top
 Profile  
 
 Post subject:
PostPosted: Fri Sep 13, 2013 8:35 am 
Offline
ResidualVM Developer

Joined: Thu Feb 28, 2013 5:48 pm
Posts: 207
Yes, both crashes are related to loading EMISound objects again.
There's a PR to turn that off for the moment, as that part is still unstable.
The call to error() is supposed to show a nice error dialog, but the plumbing isn't in place yet, so it crashes instead.


Top
 Profile  
 
 Post subject:
PostPosted: Fri Sep 13, 2013 10:55 pm 
Offline

Joined: Tue Sep 10, 2013 10:48 pm
Posts: 5
Location: United Kingdom
Botje wrote:
Yes, both crashes are related to loading EMISound objects again.
There's a PR to turn that off for the moment, as that part is still unstable.
The call to error() is supposed to show a nice error dialog, but the plumbing isn't in place yet, so it crashes instead.


Thanks for checking Botje. Glad you spotted the error.

Excuse my ignorance buts what's a PR?


Top
 Profile  
 
 Post subject:
PostPosted: Sun Sep 15, 2013 3:37 pm 
Offline
ResidualVM Developer
User avatar

Joined: Wed Nov 24, 2010 2:44 am
Posts: 325
PR = Pull Request, as in someone wrote a patchset, and submitted it for review by the team, our list of currently open Pull Requests is here:
https://github.com/residualvm/residualvm/pulls


Top
 Profile  
 
 Post subject:
PostPosted: Sun Sep 15, 2013 5:41 pm 
Offline

Joined: Tue Sep 10, 2013 10:48 pm
Posts: 5
Location: United Kingdom
somaen wrote:
PR = Pull Request, as in someone wrote a patchset, and submitted it for review by the team, our list of currently open Pull Requests is here:
https://github.com/residualvm/residualvm/pulls


Great. Cheers.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Sep 15, 2013 10:01 pm 
Offline
User avatar

Joined: Sat May 23, 2009 2:24 pm
Posts: 16
Location: Winnipeg, Manitoba, Canada
I get some pretty funky lighting issues on my Galaxy s3.

http://db.tt/5VBMcRP5
http://db.tt/KCm8NzdH

Also, when moving forward he'll randomly turn left instead of going straight. Or maybe I'm not understanding how the controls work properly? A tiny bit choppy but not much. Great work!

EDIT: EMI crashes right after the opening credits. Won't go any farther. It's also complaining that patch.m4b is corrupt. I've copied it over a couple times and it still says it. The source file is fine. I don't know if the copy process is somehow messing it up or not.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Sep 18, 2013 1:31 pm 
Offline
ResidualVM Developer
User avatar

Joined: Wed Nov 24, 2010 2:44 am
Posts: 325
Does your version of EMI work with ResidualVM on your desktop-computer?


Top
 Profile  
 
 Post subject:
PostPosted: Wed Sep 18, 2013 1:39 pm 
Offline
ResidualVM Developer

Joined: Thu Feb 28, 2013 5:48 pm
Posts: 207
I know about the lighting issues, will probably just turn it off for now.

As for the EMI thing:
Yes, it's probably a broken patch.m4b file.

Apart from that, EMI support is slowly evolving. We're not at the point where we accept bug reports yet, but you can see the current progress at http://wiki.residualvm.org/index.php/Research_on_EFMI.
If enough people are interested in testing EMI we should start up a new topic to coordinate testing and narrow down issues.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 212 posts ]  Go to page Previous  1 ... 4, 5, 6, 7, 8, 9, 10 ... 15  Next

All times are UTC


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Forum design by ScummVM team, icons by raina, adopted for ResidualVM
curved edge   curved edge