ResidualVM logo Forum Index - ResidualVM website - Contact us - Rules Login    Register     Search curved edge
It is currently Wed Apr 26, 2017 4:00 am

All times are UTC




Post new topic Reply to topic  [ 57 posts ]  Go to page Previous  1, 2, 3, 4  Next
Author Message
 Post subject:
PostPosted: Fri Mar 07, 2014 8:03 pm 
Offline
User avatar

Joined: Tue Jul 19, 2011 2:51 am
Posts: 324
Location: aka ThunderPeel2001
I just had a look through the textures. I hope you don't mind, but I wonder if you'd consider some changes? (They might be moot, because maybe you won't be able to see the differences in the game anyway!)

Here's the original:

Image

Here's yours:
Image

Here's slightly modified:
Image

Just note that the shadows around Glottis's eyes are a little lighter, and I tried to make his hair a little more red and 3D. Maybe I've just made him worse, though. It's just a suggestion! :)

https://dl.dropboxusercontent.com/u/304 ... s-mine.psd

I'm going to try and get your textures into the game.


Top
 Profile  
 
 Post subject:
PostPosted: Fri Mar 07, 2014 9:44 pm 
Offline
User avatar

Joined: Tue Jul 19, 2011 2:51 am
Posts: 324
Location: aka ThunderPeel2001
Ok, just to let you know what you need to do with your textures:

Load up a BMP file into Photoshop.

Goto: IMAGE > MODE > INDEXED COLOR

This will convert your image to 256 colours.

Then go to: IMAGE > MODE > COLOR TABLE

This will open up your current palette. Click LOAD and select glottis.act (the file you converted from glottis.cmp).

You're now using the game's colour palette.

Photoshop will automatically assign the nearest colours, so don't worry about that.

Now you can save your finished Indexed BMP out for conversion into a MAT for use in the game.

That's it!

NOTE FOR TRANSPARENCIES:

Before you do the above, you should make anything that's supposed to be transparent this colour: RGB: 255, 0, 255 (bright pink)

There's no alpha transparency, so it's either transparent, or it's not. Do not have subtle shades of pink to soften the edges of the transparency. No anti-aliasing at all. Just solid blocks of pink for anything that you want transparent.

Then convert to Indexed and apply the new colour table (as above).

Once done, you need to colour all the bright pink areas (color #2 in the palette) to the first black in the palette (color #1). This is where I get hazy, unfortunately. I just can't see how you select and force the use of specific colour # from a palette in Photoshop.

Surely you can do this? Hmm! I'll keep looking.


Top
 Profile  
 
 Post subject:
PostPosted: Fri Mar 07, 2014 10:09 pm 
Offline

Joined: Sat Nov 17, 2012 11:46 pm
Posts: 33
Alright that all sounds awesome!

Just FYI what I'm bring to the group are first draft textures and I have no problem with people in the team tweaking or giving me suggestions. Now that I know how to put this in the game I can present a more finished product to you guys. Thanks again man! I hope you like what I'm doing and I'm excited to help!


Top
 Profile  
 
 Post subject:
PostPosted: Fri Mar 07, 2014 10:25 pm 
Offline

Joined: Sat Nov 17, 2012 11:46 pm
Posts: 33
There only one problem I'm running into I'm sure it's something I'm doing. I converted the CMP to an ACT and when I apply it to the indexed BMP so that it changes pallets it looks like this.

http://i.imgur.com/6Clqt1B.png

Which I'm sure you can agree looks nothing like the original texture and I copied the exact color shades from the original so I doubt there any reason to disagree with the pallet.


Top
 Profile  
 
 Post subject:
PostPosted: Fri Mar 07, 2014 10:31 pm 
Offline

Joined: Sat Nov 17, 2012 11:46 pm
Posts: 33
And this when I tried cafe manny's chest.

http://i.imgur.com/x248wPf.png

Will these look ok in game?


Top
 Profile  
 
 Post subject:
PostPosted: Sat Mar 08, 2014 12:45 pm 
Offline
User avatar

Joined: Thu Jun 21, 2012 3:00 pm
Posts: 129
Are you sure you had the correct palette loaded when you exported it? I mean after you clicked the "Combine" button, you might have loaded a different palette and exported that one.

Not sure what's going on there since I've never encountered this before.

You can even just load a palette, e.g. glottis.cmp, and press "Save Palette as *.ACT".

therainydaze wrote:
...and I copied the exact color shades from the original so I doubt there any reason to disagree with the pallet.


How did you do this exactly? Or did you mean when painting?
Also, color positions are important in the palette, which means they have to be in the exact order. (which is why we don't modify palettes, since multiple textures use the same one)

Also when in photoshop, make sure you LOAD the correct palette, since after converting it will either use the system pallete or the previous palette you've used.

EDIT: OK, I can see you've used the correct palette, not sure why you're getting this. To me it looks as if the colors have been reversed (e.g. color 1 has become color 256, color 2 has become 255 and so on...). And I was wrong about the saving thing, seems you must combine first, I wonder why I made it like that.


Top
 Profile  
 
 Post subject:
PostPosted: Sat Mar 08, 2014 11:15 pm 
Offline

Joined: Sat Nov 17, 2012 11:46 pm
Posts: 33
When I said I used the exact colors I meant when I was painting I just used the shades that were in the original texture.

I extracted the ACT straight from the CMP.

Do I need a different ACT file for each texture? Maybe something is happening that I don't even know. If we can't figure this out I can just make a video of me doing it and maybe you'll see something wrong that I don't.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Mar 09, 2014 1:04 am 
Offline
User avatar

Joined: Thu Jun 21, 2012 3:00 pm
Posts: 129
If the images look OK in The GrimReaper (before you modify them), then the palette is OK too. You can use one palette file for multiple images in Photoshop, given that you use the correct palette file of course.

For the images above:
gl_jaw.mat uses glottis.cmp
mc_chest.mat uses cafe.cmp

You can even use similar colors when painting in RGB, and when you convert to Indexed and apply the palette, it will guess which the closest colors from the palette are, and apply those.
(e.g. if the palette doesn't have blue and you've painted with blue, it will most likely replace it with light gray, if it has light gray)

If you can't figure it or if you haven't already, by all means make the video.

EDIT: Oh and by the way, if you're saving them as *.BMP files out of PS, make sure to have Windows format selected, 8-bit, no RLE compression and don't flip row order.


Top
 Profile  
 
 Post subject:
PostPosted: Sun Mar 09, 2014 2:38 am 
Offline

Joined: Sat Nov 17, 2012 11:46 pm
Posts: 33
Alright I don't see anything I'm doing wrong so I'll make the video soon.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Mar 10, 2014 4:45 am 
Offline

Joined: Sat Nov 17, 2012 11:46 pm
Posts: 33
http://www.youtube.com/watch?v=hAR_NsNna4s


Top
 Profile  
 
 Post subject:
PostPosted: Mon Mar 10, 2014 6:27 am 
Offline
User avatar

Joined: Thu Jun 21, 2012 3:00 pm
Posts: 129
Hmmm, OK so I don't initially see what's wrong, maybe JohnnyWalker2001 will spot something I didn't. For now you can try this:

- Don't use GrimReaper 0.2 at all. Try using GrimReaper Deluxe for everything. (Load *.CMP, then load *.MAT, then save palette as *.ACT)

- Delete the previous *.ACT file, and then write a new one, don't overwrite it. There's a possibility that something screwy happens when writing over an existing file (my guess is that possibly it adds to the values in the file instead of writing new ones). Same for the *.MAT, don't overwrite, just delete the previous one first if you want to save in the same location (with the same filename).

- If all else fails, try saving the files as *.PNG from the GrimReaper (there will be a dropdown box to choose extension when exporting frame), but don't save as *.JPG because artifacting might happen (it shouldn't, but I used an existing proprietary .NET class when writing that one, so I'm not a 100% sure if it won't deteriorate quality in exchange for size).
Also, try re-saving your files as non-compressed *.PNGs, open them up again, convert to RGB, convert to Index and apply the correct palette.

- And lastly, if you're editing Glottis from Year One, use the files from DATA000.LAB. There might be files with the same names in the other DATA***.LABs, but might contain different data (I'm not a 100% sure about this one, I don't really think it's that, but doesn't hurt to be careful).

Check these out, and tell me if any of it helped you.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Mar 10, 2014 11:23 pm 
Offline
User avatar

Joined: Tue Jul 19, 2011 2:51 am
Posts: 324
Location: aka ThunderPeel2001
Hey, you did everything right in that video. I kind of suspect that you have converted the wrong .cmp file into an .act file. Or maybe Grim Reaper Deluxe has a bug in it that previous versions don't have when it comes to CMP files?

I know this: When I apply glottis.act to your BMPs, they don't change. The colours are identical. There's definitely an issue with your ACT file -- or maybe an obscure setting in Photoshop.

EDIT: Hmm. You know, strangely, the color table looks absolutely right when I pause the video. Your ACT looks right. Very odd. I'll keep digging.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Mar 10, 2014 11:49 pm 
Offline
User avatar

Joined: Tue Jul 19, 2011 2:51 am
Posts: 324
Location: aka ThunderPeel2001
Argh. Now I'm getting the same problem as you, Michael! It was working fine, and then I changed something when I converted to Indexed, and now all the colours are messed up.

I'm sure I'll be able to fix it, though. Just give me a little time! :-/


Last edited by JohnnyWalker2001 on Tue Mar 11, 2014 12:04 am, edited 1 time in total.

Top
 Profile  
 
 Post subject:
PostPosted: Mon Mar 10, 2014 11:52 pm 
Offline
User avatar

Joined: Thu Jun 21, 2012 3:00 pm
Posts: 129
JohnnyWalker2001 wrote:
Hmm. You know, strangely, the color table looks absolutely right when I pause the video. Your ACT looks right. Very odd. I'll keep digging.


Yeah, I noticed that too, which has me baffled. It could very well be a bug in the Deluxe, though the Deluxe is a clean rewrite, much better than the previous one (so I hope it's not a bug :P) but in the video he uses the GrimReaper 0.2 (or maybe it's just for demonstration purposes?) to export, which is why I say to use the Deluxe. Weird thing is, this hasn't happened to me with either version, so I'm not really sure what it could be :/

P.S.: The previous version needs the FreeImage.dll, the Deluxe doesn't need anything (apart from the 3D lib which is already packed in it).


Top
 Profile  
 
 Post subject:
PostPosted: Mon Mar 10, 2014 11:58 pm 
Offline
User avatar

Joined: Tue Jul 19, 2011 2:51 am
Posts: 324
Location: aka ThunderPeel2001
Fixed!

https://www.youtube.com/watch?v=SBwBjesph00

Bad instructions on my part. Sorry!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 57 posts ]  Go to page Previous  1, 2, 3, 4  Next

All times are UTC


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Forum design by ScummVM team, icons by raina, adopted for ResidualVM
curved edge   curved edge