ResidualVM logo Forum Index - ResidualVM website - Contact us - Rules Login    Register     Search curved edge
It is currently Sat Nov 17, 2018 11:01 am

All times are UTC




Post new topic Reply to topic  [ 85 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6  Next
Author Message
 Post subject:
PostPosted: Mon May 16, 2011 4:24 am 
Offline
ResidualVM Developer
User avatar

Joined: Wed Nov 24, 2010 2:44 am
Posts: 322
Both 4.0 and 4.2 are installed with XCode, the export-lines you added makes 4.2 override 4.0 as default compiler. So... you have 4.2


Top
 Profile  
 
 Post subject:
PostPosted: Mon May 16, 2011 6:48 am 
Offline

Joined: Tue May 10, 2011 8:05 am
Posts: 45
Ok, i will try it again and report, if make bundle works then.

But i am a bit concerned about the savegame issue :(
Sound works fine now, and it seems there is some working AA now, because the game dont look jaggy any more but still runs fluid.

I mean, if i can't load a savegame, the whole thing becomes a bit unusefull.

Then playing Grim via Win98 in vpc5 be the only option for me.
Maybe then i'll have to place a big fan beside the powerbook, to keep it from melting ;)

Just an idea: to make sure, i got a working (patched) Grim Version
How can i check this? I think, if i see subtitles in cutscenes (like in the intro Scene) i am fine, right? Subtitles are sometimes bugged, for example when driving to the land of living, the last sentence, said by eva still remains on bottom of the screen. After returning with little bruno, the subtitles of manny and him are mixed, i mean they both overlap and are not readable.


Top
 Profile  
 
 Post subject:
PostPosted: Mon May 16, 2011 7:21 am 
Offline
ResidualVM Developer
User avatar

Joined: Wed Nov 24, 2010 2:44 am
Posts: 322
Yes, it's a known issue, subtitles during cutscenes are bugged.

But, if you see them, then you have the patched version.


Top
 Profile  
 
 Post subject:
PostPosted: Mon May 16, 2011 8:00 am 
Offline

Joined: Tue May 10, 2011 8:05 am
Posts: 45
Ah, ok thx again!

So, i will compile it again later, this time it should be done with gcc 4.2, asuming the .profile was setup right.

First i must do "make" when in the residual directory, then try "make bundle" and after that, there should be a working app with icon and normally loading a savegame should work then - so that is the plan.

Is there a need to set a save path in residual? First i did not setup one, but in grim game menu, the savegames i made, were found by the game.

Is the residual path only for the auto-save?
Is setting up a savepath essential for savegames to work right?

Greetings
Elo


Top
 Profile  
 
 Post subject:
PostPosted: Mon May 16, 2011 9:07 am 
Offline
ResidualVM Developer
User avatar

Joined: Mon Mar 21, 2011 9:20 am
Posts: 139
Location: Belluno, Italy
The only thing i can think of about the savegames issues is an endianness problem. PowerPC is big endian, while Intel is little endian.
I don't own a big endian machine though, so i can't directly fix it. I might send you a patch and you see if it works.


Top
 Profile  
 
 Post subject:
PostPosted: Mon May 16, 2011 1:02 pm 
Offline

Joined: Tue May 10, 2011 8:05 am
Posts: 45
giucam wrote:
The only thing i can think of about the savegames issues is an endianness problem. PowerPC is big endian, while Intel is little endian.
I don't own a big endian machine though, so i can't directly fix it. I might send you a patch and you see if it works.


Awesome, i would test it and report back to you.
In a few hours i will build residual again (with gcc 4.2, i think/hope) and have a look, if the load issue still exists.

Unbelieveable positive support here, from all of you, thx a lot!


Top
 Profile  
 
 Post subject:
PostPosted: Mon May 16, 2011 3:09 pm 
Offline
ResidualVM Developer
User avatar

Joined: Wed Nov 24, 2010 2:44 am
Posts: 322
Elowan wrote:
Is the residual path only for the auto-save?
Is setting up a savepath essential for savegames to work right?


No, and no.

It's set to pretty decent defaults.


Top
 Profile  
 
 Post subject:
PostPosted: Mon May 16, 2011 4:35 pm 
Offline

Joined: Tue May 10, 2011 8:05 am
Posts: 45
hmm, after changing the env. var. (macports should use gcc 4.2), building didn´t work anymore:

Code:
Powerbook:~ gforce$ cd residual
Powerbook:residual gforce$ make
fatal: cannot describe '1271a8f87f729fc6849b456a879e39ea4582a7b5'
make: Nothing to be done for `all'.


Code:
Powerbook:residual gforce$ make bundle
fatal: cannot describe '1271a8f87f729fc6849b456a879e39ea4582a7b5'
g++   -force_cpusubtype_ALL -o residual-static backends/platform/sdl/hardwarekeys.o backends/platform/sdl/main.o backends/platform/sdl/sdl.o backends/platform/sdl/posix/posix-main.o backends/platform/sdl/posix/posix.o backends/platform/sdl/macosx/macosx-main.o backends/platform/sdl/macosx/macosx.o   base/libbase.a engines/grim/libgrim.a gui/libgui.a backends/libbackends.a engines/libengines.a video/libvideo.a graphics/libgraphics.a audio/libaudio.a common/libcommon.a \
      -framework CoreMIDI \
      `/sw/bin/sdl-config --static-libs` \
      -lz \
       \
      -lSystemStubs
/bin/sh: /sw/bin/sdl-config: No such file or directory
Undefined symbols:
  "_glReadPixels", referenced from:
      SdlGraphicsManager::clearOverlay()       in libbackends.a(sdl-graphics.o)
      Grim::GfxOpenGL::storeDisplay()     in libgrim.a(gfx_opengl.o)
...
...


what is the problem?


Top
 Profile  
 
 Post subject:
PostPosted: Mon May 16, 2011 6:27 pm 
Offline
ResidualVM Developer
User avatar

Joined: Wed Nov 24, 2010 2:44 am
Posts: 322
For some reason it falls back to thinking that you have fink (/sw) instead of macports (/opt/local)


Top
 Profile  
 
 Post subject:
PostPosted: Mon May 16, 2011 7:02 pm 
Offline

Joined: Tue May 10, 2011 8:05 am
Posts: 45
ok, after deleting the complete residual directory and downloading git clone again, fixing the "64bit issue", "make bundle" still fails (same error), but "make" works again.

so, i made a new residual version, played a bit and saved.
now, after loading the saved game, mannys walking animation is running, while he stands still. the game does not react any more - only force-quit ends this...


here is some code snippet:

Code:
WARNING: The node 0 was already allocated. swivel_left.key!
WARNING: The node 0 was already allocated. ma_reach.key!
WARNING: The node 0 was already allocated. ma_reach.key!
WARNING: The node 0 was already allocated. ma_reach.key!
Imuse::restoreState() started.
Imuse::restoreState() finished.
GrimEngine::savegameRestore() finished.
lua: (null)
Active Stack:
   `gettable' tag method at line 2346 [in file Scripts\_system.lua]
   function (Scripts\_options.lua:2937)
   function (Scripts\_options.lua:2894)
WARNING: L1_SetGamma, implement opcode, level: 0!
lua: (null)
Active Stack:
   `error' tag method at line 2365 [in file Scripts\_system.lua]
   function getglobal [in file (C)]
   function (Scripts\_manny.lua:1013)
lua: bad argument #1 to function `getglobal' (string expected)
Active Stack:
   `error' tag method at line 2371 [in file Scripts\_system.lua]
   function getglobal [in file (C)]
   function (Scripts\_manny.lua:1013)


any ideas?

it´s a bit strange... the savegame loads (exact at this point, where i saved it before) but crashes/closes after 2-3 seconds or it freezes with running aninmation on manny - but he doesn´t really move or react to arrow-keys...

in the load option from menu, the "puzzle-tiles" in the above area are shown, but the little preview image of the savegame won´t - it´s just a grey square.

sorry, but don´t know how to describe this better. i don´t know, what else informations i could provide, helping you to solve the issue and/or see, why it´s failing on loading savegames :(

anyway, was a hard day, going to sleep. maybe tomorrow, we´ll see?!

greetings and goodN8


Top
 Profile  
 
 Post subject:
PostPosted: Mon May 16, 2011 9:11 pm 
Offline
ResidualVM Developer
User avatar

Joined: Mon Mar 21, 2011 9:20 am
Posts: 139
Location: Belluno, Italy
The restore should be fixed now with this commit.
Only the restore though, not the screenshot image.


Top
 Profile  
 
 Post subject:
PostPosted: Mon May 16, 2011 9:27 pm 
Offline
ResidualVM Developer
User avatar

Joined: Wed Nov 24, 2010 2:44 am
Posts: 322
As a side note, I tested that patch on my PPC, and it still has problems with a few things.

Try this:
Start the game, skip the opening cut-scene, then save
Now reload that save.

What happens at my Powerbook:
The save loads, but Manny is invisible, then the door opens, and we go into the hallway, where Manny is again visible. (All of this without controlling Manny at all).


Top
 Profile  
 
 Post subject:
PostPosted: Tue May 17, 2011 9:00 am 
Offline

Joined: Tue May 10, 2011 8:05 am
Posts: 45
Hmm, does loading a savegame work at another point? Like when you take the elevator and go outside the building and perform a save/load?

Just in case, how to install the patch? I am on iphone atm ...

Thx in advance


Top
 Profile  
 
 Post subject:
PostPosted: Tue May 17, 2011 2:13 pm 
Offline
ResidualVM Developer
User avatar

Joined: Mon Mar 21, 2011 9:20 am
Posts: 139
Location: Belluno, Italy
Elowan wrote:
Just in case, how to install the patch? I am on iphone atm ...


Do a git pull and make again.


Top
 Profile  
 
 Post subject:
PostPosted: Tue May 17, 2011 4:29 pm 
Offline
ResidualVM Developer
User avatar

Joined: Wed Nov 24, 2010 2:44 am
Posts: 322
Also, fix for make-bundle:

Open "configure" in a texteditor, and change line 131 from:
_staticlibpath=/sw

to:

_staticlibpath=/opt/local

That fixes make bundle atleast for me. (it also has the side-benefit of being a one-time fix). The alternative, is to use configure like this:

./configure --with-staticlib-prefix=/opt/local

(Which, really should be the first solution, when I think about it).

Oh, and saves work alot better in the latest commits.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 85 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6  Next

All times are UTC


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Forum design by ScummVM team, icons by raina, adopted for ResidualVM
curved edge   curved edge